http://www.mg-rover-teile.de

Autor Thema: Fehlerquelle an Motorsteuergerät K-Serie, MEMS 1.9 geht nicht in Ruhestrom  (Gelesen 10598 mal)

Offline rover214i

  • MG/Rover Forum Mitglied
  • ****
  • Beiträge: 240
  • Geschlecht: Männlich
  • Fahrzeug: 214i (RF)
Hallo Zusammen,

vor Beginn meines ersten Beitrags möchte ich mich zuerst bei denen bedanken, die dieses informative Forum eingerichtet haben, und insbesondere bei den Teilnehmern, die mit ihren Fragen und Antworten allen interessierten Rover-Freunden helfen, mehr über ihren fahrbaren Untersatz zu erfahren.

Auch ich konnte bereits vom bereit gestellten Wissen profitieren, als ich im letzten Jahr das Airbag-Steuergerät meines 214i (Typ RF) von 1997 suchte, weil die Warnlampe nach 6 Sekunden immer Dauerlicht gab und das Notebook den Fehler „Lenkradkoppler“ ausgab. (Der war es aber gar nicht, sondern das Steuergerät selbst. Die Selbstdiagnose ist dafür leider nicht intelligent genug).

Nun könnte es ja sein, daß für den einen oder anderen meine Erkenntnisse bei der Fehlersuche an meinem Motor-Steuergerät vom Typ MEMS MKC104011 Version 1.9 von Interesse sind. 

Ich muß aber im Interesse Aller eindringlich vor zu großem Eifer warnen:
Die Platine der Steuerelektronik besteht aus 4 Layern, das heißt, es gibt 4 Ebenen mit Leiterbahnen, davon zwei Ebenen „im Inneren“ der Platine, die bestenfalls gegen helles Licht betrachtet zu sehen sind. Das erschwert das Auslöten von durchgesteckten Bauteilen, insbesondere wenn auch Leiterbahnen „mittendrin“ dranhängen, die beim Auslöten Schaden nehmen können.
Wer noch nie ein SMD-Bauteil (SMD = Surface Mounted Device) ausgelötet hat, macht sehr wahscheinlich mehr kaputt als heil und sollte den Austausch einer erfahrenen Person seines Vertrauens überlassen. Aus diesem Grund muß ich eine Haftung meiner Person jedweder Art für fehlgeschlagene Reparaturversuche bzw. einem daraus resultierenden Folgeschaden ausschließen. Dennoch sind die von mir gegebenen Informationen nach bestem Wissen und Gewissen erstellt.

Zum Öffnen des Gehäuses:
Für die 4 Schrauben benötigte ich ein TORX-Bit TR20 mit Loch.
Die Gehäuse-Bestandteile sind mit Dichtmasse verklebt. Zur Trennung der Gehäuseteile verwendete ich eine regelbare Heißluftpistole, denn bei höherer Temperatur wird die Versiegelung weicher.Trotz Erwärmung verlangte die Öffnung viel Geduld und Vorsicht.
Die eingebauten Leistungs-Halbleiter werden über das Gehäuse gekühlt. Aus diesem Grund muß die Gehäusetemperatur unter 150 Grad bleiben.

Meine Steuerelektronik hatte 2 Fehler:
1.) Der typische Fall: das Hauptrelais zieht mit dem Einschalten der Zündung an, fällt aber nach Abschalten der Zündung nicht mehr ab. Die Folge: es floß ein Strom von ca. 0,5 Ampere, die Batterie ist rechnerisch nach  2 Tagen halbleer (0,5 A * 24 Stunden = 12 Amperestunden pro Tag).
Um diesen Fehler zu finden, habe ich, so gut es bei 4 Layern ging, versucht, ein Schaltbild für diesen Zweig zu erstellen. Ohne für die Vollständigkeit bzw. Richtigkeit eine Garantie zu geben, füge ich meine Skizze hier bei. Sie kann bei der Fehlersuche zumindest behilflich sein.

In meinem Fall war der Grund ein hochohmiger Vorwiderstand von 100 Kiloohm (Bauteilaufdruck 104 => eine Zehn mit 4 nachfolgenden Nullen).  Nachträgliche Anmerkung: 100 Kiloohm entspricht 100 000 Ohm
Der Widerstand ist in der beigefügten Grafik mit einem roten Rahmen umgeben.


Theoretisch könnte auch ein konventioneller Widerstand aufgelötet werden mit dem Farbcode braun schwarz gelb. Speziell die Erschütterungen im Fahrbetrieb steckt ein SMD-Widerstand wegen viel geringerer träger Masse aber besser weg.
Nach dem Austausch des Widerstands fällt das Hauptrelais ca. 5 Minuten nach Abschalten der Zündung wieder ab, der Ruhetrom beträgt danach nur noch ca. 0,03 Ampere.
/*EDIT
Warnung: In dem Moment, in dem die Zündung eingeschaltet wird, reicht bei meinem 214i der 10 Ampere-Meßbereich gerade eben aus, wenn kein Radio, Gebläse, heizbare Heckscheibe oder ähnliches eingeschaltet sind;
und bitte niemals den Anlasser betätigen, sonst lassen nicht nur "geschmolzene" Meßkabel grüßen.
EDIT*/

2.) Wurde die Batterie abgeklemmt und später wieder angeschlossen, wurde die Wegfahrsperre durch den glatten Knopf der Fernbedienung nicht deaktiviert. Beim Entriegeln  zeigte die Leuchtdiode in der Armaturentafel durch aufgeregtes Blinken (wie beim Verriegeln), daß die Deaktivierung nicht durchgeführt wurde. Auch wechselweises Drücken der beiden Knöpfe der Fernbedienung führten lediglich zu korrekten Aktionen der Zentralverriegelung.  Es dauerte mindestens gefühlte 10 Minuten, bis die Fernbedienung die Wegfahrsperre deaktivieren konnte.
Auch hier war ein SMD-Widerstand von 10 Kiloohm (Bauteilaufdruck 103 => eine Zehn mit 3 nachfolgenden Nullen) hochohmig geworden.
Dieser Widerstand ist in der beigefügten Grafik mit einem gelben Rahmen umgeben und wird für den 5-Volt-Spannungsregler vom Typ L4947R verwendet:
wenn nach Anschließen der Batterie die stabilisierten 5 Volt verfügbar sind, wird ein zeitverzögerter Reset des Mikroprozessors durchgeführt. Details hierzu können dem Datenblatt entnommen werden, verfügbar zum Beispiel  unter www.alldatasheet.com.

/*EDIT: Die Widerstände können im eingebauten Zustand gemessen werden, wenn man ein gutes Digital-Multimeter (DMM) verwendet (in der Regel nicht das Sonderangebot zu 4,99 EURO), andernfalls kann die Meßspannung so groß sein, daß auch Silizium-Transistoren und/oder -Dioden leitend werden und das Meßergebnis verfälschen. Um das zu vermeiden, ist eine Meßspannung unter 0,7 Volt erforderlich.
Mein DMM mißt Widerstände zwar mit ca. 1,3 Volt (obwohl kein Sonderangebot), aber in diesen beiden Fällen kann damit trotzdem eine einwandfreie Diagnose erstellt werden.
Ein Widerstand sollte >>spätestens<< dann erneuert werden, wenn der gemessene Wert ausserhalb der Toleranz von 10% liegt (der 10 Kiloohm-Widerstand darf also zwischen 9 und 11 Kiloohm liegen, der 100 Kiloohm-Widerstand analog zwischen 90 und 110 Kiloohm)
EDIT*/

Nachher ist man klüger: Um die defekten Widerstände auszuwechseln, hätte ich in meinem Fall nur das dünne Alublech vom Gehäuse entfernen müssen.

Die Lötstellen habe ich mit Dichtmasse gegen Feuchtigkeitseinflüsse isoliert und das Gehäuse wieder „wetterfest“ versiegelt.

Ich hoffe, daß in Zukunft kein weiterer Eingriff notwendig wird.

Allzeit gute Fahrt wünscht

Karl


« Letzte Änderung: 05. März 2010, 20:47:29 von Gert »

Offline Dieter K

  • MG/Rover Forum Mitglied
  • ****
  • Beiträge: 246
  • Geschlecht: Männlich
  • MGF/TF
    • www.mgfcar.de
Re: MEMS MKC104011 (Rover 214i)
« Antwort #1 am: 20. April 2008, 00:21:10 »
1. Sahne !
Das trifft wahrscheinlich 10-20 % der ECU Ausfälle, nach dem was ich so in den letzten 10 Jahren verfolgt habe.
Da freuen sich nicht nur die Rover Fahrer. (Minis und MG's haben auch das 1.9er drin)

Vielen Dank für die ausführliche Beschreibung.

Gruß
Dieter Könnecke

mini-zr160

  • Gast
Re: MEMS MKC104011 (Rover 214i)
« Antwort #2 am: 20. April 2008, 00:26:20 »
öhm welcher mini ??? :-D  <- vergaserfreak :-D

Offline Manic Mechanic

  • Moderator
  • MG/Rover Forum Mitglied
  • ****
  • Beiträge: 7612
  • Donne e Motori, Gioie e Dolori
  • Fahrzeug: Blaues Wunder
Re: MEMS MKC104011 (Rover 214i)
« Antwort #3 am: 20. April 2008, 08:39:11 »
Hast Du auch nen Kniff für das zeitweise abfallende Benzinpumpenrelais? Liegt auch am Steuergerät, nur woran? Dann hättest Du fast alle Wehwehchen der 1.9er genannt... ;-)

Ansonsten große Klasse, wenngleich Du Recht hast, dass bei Multilayern schnell was hopps geht, wenn man mit dem 100W Engel Löter :-D drangeht. Da werden die meisten (mich eingeschlossen) dran scheitern. 
DAFUQ?

Offline Tom

  • Testbook-Spezl
  • MG/Rover Forum Mitglied
  • *****
  • Beiträge: 4335
  • Geschlecht: Männlich
  • Rover-Lover.com
    • ROVER-LOVER.com
Re: MEMS MKC104011 (Rover 214i)
« Antwort #4 am: 20. April 2008, 10:35:52 »
Wow, super Beitrag! Wie bist Du auf die Widerstände gekommen, ohne Schaltplan? Einen nach dem anderen durchgemessen?
Was kann die Ursache dafür sein, zuviel Verlustleistung für den SMD-Widerstand?
T4 Testbook-Services
  • X-Power Upgrades
  • ZCS-Codeberechnung
  • Tachofehler beheben & anlernen
  • R75 Schlüssel-Barcodes berechnen
  • Pektron SCU klonen / reparieren

Offline Dieter K

  • MG/Rover Forum Mitglied
  • ****
  • Beiträge: 246
  • Geschlecht: Männlich
  • MGF/TF
    • www.mgfcar.de
Re: MEMS MKC104011 (Rover 214i)
« Antwort #5 am: 20. April 2008, 21:50:43 »
Ein Problem bei unserem ECU ist, das es jedes Jahr älter wird und die Zuverlässigkeit von SMD Schaltungen *Design -State of the Art 1993?-* nicht zunimmt ;)
SMD Lötstellen gehören nun mal bei Autos zum Unzuverlässigstem, und die kommen gleich nach den Steckverbindungen....
Das ist so, und eine der Hauptursachen sind die Temperaturwechsel und die unterschiedlichen Dehnungskoeffizienten der Materialien.
Meine bescheidene Prognose: bei neuester Technik mit bleifreien Verbindungen wird das noch schlimmer (OK, nicht mehr unser MG-Rover Problem)

Positiv natürlich, das es immer wieder User aus dem Elektronikbereich gibt, die verrückt genug sind solange nach individuellen Fehlern zu suchen, bis das Ding wieder läuft. und dann auch noch strukturiert darüber berichten :)
User *rover214i* ist kein  Einzelfall ;); kenne da noch zwei weitere, die sich aus derr Mini-Scene heraus mit Detailfehlern beschäftigen, bzw. Lösungen fanden.
 :*
http://www.mini-forum.de/elektrik-11/das-spi-ecu-testbook-projekt-38032.html
Na, jedenfalls gehen die Informationen nicht verloren. :angel:

 
Gruß
Dieter Könnecke

Offline rover214i

  • MG/Rover Forum Mitglied
  • ****
  • Beiträge: 240
  • Geschlecht: Männlich
  • Fahrzeug: 214i (RF)
Re: MEMS MKC104011 (Rover 214i)
« Antwort #6 am: 21. April 2008, 13:53:58 »
@Dieter K
Weil ich das Glück habe, täglich mit dem Job-Ticket (ÖPNV) fahren zu können, konnte ich mir die Zeit zur Fehlersuche nehmen. Müßte ich mit dem Rover jeden Tag x Kilometer abreißen, wäre  das nicht gelungen.

@Manic Mechanic
Nein, leider habe ich keinen Tip für das zeitweise abfallende Benzinpumpenrelais.
Da mein Gehäuse inzwischen wieder versiegelt ist, kann ich auch nicht mehr das Schaltungslayout feststellen.

@Tom
Beim Spannungsregler habe ich so "auf Probe" gemessen. Für die kompliziertere Schaltung des Hauptrelais kam ich aber nicht umhin, zuerst das Schaltbild zu erstellen, um die beteiligten Bauteile und ihre Wirkungsweise verstehen zu können. Das war auch nicht lustig: mit 2 Klemmprüfspitzen "bewaffnet", die jeweils eine Stecknadel festklemmten, weil Stecknadeln problemlos die "Gummischutzschicht" durchstoßen, ohne Riesenlöcher zu hinterlassen. Und wie gesagt: die Leitungsführung geht auch "mitten durch" die Platine. Da muß man erst mal feststellen, wo die Leitung von Anschluß 4 überhaupt alles hinführt. Und von den Bauteilen gibt es auch viele Abzweigungen.
Erst mit Schaltbild lohnt es sich wirklich, Bateile zu messen. Aber auch das ist teilweise problematisch.
Beispiel: der Transistor, dessen Basis-Emitter-Strecke parallel zum 2R8-Widerstand liegt, mußte ausgelötet werden, um die B-E-Strecke messen zu können. Der Wert des Widerstands war mir nicht bekannt. Ist alles eingebaut, dann hätte der gemessene Wert vom Widerstand oder von einer "durchgeschlagenen" B-E-Strecke stammen können.
Zugegeben, ich hatte Glück, daß es nur der Widerstand war. Wenn das ECU-IC hin ist, hilft nur noch Austausch...

Dieter K hat die Ausfallgründe völlig richtig genannt.

Ein Rechenbeispiel noch dazu:
Ein 100-Kiloohm-Widerstand, der direkt an die 12-Volt-Batterie angeschlossen würde, ließe einen Strom von 12/100000 Ampere fließen (U=R*I => I=U/R). Die Belastung des Widerstands beträgt hierbei 12*12/100000 = 0,00144 Watt (P=U*I). Das hält dieser Widerstand locker durch.
Der 10-Kiloohm-Widerstand hätte die  10-fache Belastung des 100-Kiloohm-Widerstands, also 0,0144 Watt.

Die reale Belastung ist sogar geringer, weil der Widerstand in Reihe mit 2 Transistoren liegt:
a) dem Schalttransistor innerhalb des ECU-IC's
b) dem zu schaltenden Transistor
c) beträgt die Versorgungsspannung des IC's lediglich 5 Volt

Viele Grüße

Karl
« Letzte Änderung: 24. April 2008, 13:17:40 von rover214i »

Nils

  • Gast
Re: MEMS MKC104011 (Rover 214i)
« Antwort #7 am: 21. April 2008, 17:20:07 »
Bravo,

FAQ-Bereich, FAQ-Bereich, FAQ-Bereich.......? :)

Offline Henry

  • FAQ/Web-Team
  • MG/Rover Forum Mitglied
  • ***
  • Beiträge: 2224
  • Geschlecht: Männlich
    • Autoservice und Selbsthilfewerkstatt Oranienburg
Re: MEMS MKC104011 (Rover 214i)
« Antwort #8 am: 21. April 2008, 18:22:33 »
Bravo,

FAQ-Bereich, FAQ-Bereich, FAQ-Bereich.......? :)

Nu mach schon :)

Offline rover214i

  • MG/Rover Forum Mitglied
  • ****
  • Beiträge: 240
  • Geschlecht: Männlich
  • Fahrzeug: 214i (RF)
Re: MEMS MKC104011 (Rover 214i)
« Antwort #9 am: 21. April 2008, 19:50:42 »
Leider habe ich mit meinen fast 50 Lenzen (noch) nicht genügend Erfahrung, um mit der Bemerkung "FAQ-Bereich" was anfangen zu können. Klar, FAQ meint frequently asked questions. Bedeutet das jetzt, daß ich etwas faksch gemacht oder falsch eingestellt habe?

In jedem Fall wollte ich noch eine Ergänzung liefern.
Durch das Schaltbild ist ja noch nicht klar, wo die Bauteile auf der Platine zu finden sind.
Diesem Mißstand möchte ich jetzt abhelfen.
In der folgenden Grafik findet sich wieder mal ein roter Rahmen. In diesem Bereich sind sowohl auf als auch unter der Platine die Bauteile des Schaltbildes wieder zu finden (mit Ausnahme des 100-Kiloohm-Widerstands natürlich, der dicht beim Haupt-IC zu finden ist).



Grüße

Karl

Offline Henry

  • FAQ/Web-Team
  • MG/Rover Forum Mitglied
  • ***
  • Beiträge: 2224
  • Geschlecht: Männlich
    • Autoservice und Selbsthilfewerkstatt Oranienburg
Re: MEMS MKC104011 (Rover 214i)
« Antwort #10 am: 21. April 2008, 19:55:32 »
Nein nein hast alles richtig gemacht:) Deine Anleitung is nur so gut das wir die in den Faq Bereich einstellen werden... Das ham noch net viele geschafft so schnell da rein zu kommen  8)

hudy99

  • Gast
Re: MEMS MKC104011 (Rover 214i)
« Antwort #11 am: 05. März 2010, 14:48:28 »
Als ich das Steuergerät vor mir geöffnet liegen sah, dachte ich "alle Achtung" da kann man doch bestimmt keinen Fehler finden! Die smd Widerstände sind so klein wie Flöhe und ich soll denen eine Herzoperation verpassen *lach*

lg heinz
www.carmy.de

Offline Tom

  • Testbook-Spezl
  • MG/Rover Forum Mitglied
  • *****
  • Beiträge: 4335
  • Geschlecht: Männlich
  • Rover-Lover.com
    • ROVER-LOVER.com
Leider sieht MKC104001 drinnen total anders aus
T4 Testbook-Services
  • X-Power Upgrades
  • ZCS-Codeberechnung
  • Tachofehler beheben & anlernen
  • R75 Schlüssel-Barcodes berechnen
  • Pektron SCU klonen / reparieren